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Express Tools

The GstarCAD Express Tools contain a library of productivity tools designed to help you extend the power of your design. They
are easy to use, easily integrated into your menus and toolbars, and cover a wide range of functions, including dimensioning,
drawing, and selecting and modifying objects. GstarCAD Express Tools are organized on:

1. Block Tools

Change base: The CHANGEBASE command allows changing the
base point position of a block. You can move the base point and
keep objects staying in same position, or move objects and keep
base point staying in same position

Menu: Express tools>Blocks> Change Base
Command Entry: CHANGEBASE
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Block Break: Working with block references that represent symbols are essential in some industrial application drawings like

electrical schematics, piping, etc.

But a headache comes when try to place these blocks accurately overlapping or even breaking other objects on your drawing.
Now get rid of this headache with BLOCKBREAK command. This innovative tool is able to wipeout or breaks an object that is

overlapped by a reference block.

For example, insome cases we may need to insert block symbols into a cable line in electrical schematic. And normally the
cable line is required to be broken by the symbols at where the symbols are inserted. Similar request are also exists in other

application designs.

Menu: Express tools>Blocks>Block Break
Command Entry: BLOCKBREAK

Block break dialog box:

Name: List all available blocks created in the drawing.

Browse: Browse to open specific drawing file. Name:
Pick: You can pick an existing block reference in the St
current drawing. -
Scale: Scales the block reference size according to X,

Y and Z coordinates. Uniform Scale option keeps the e
original size of block reference. z

Rotation: You can rotate a block reference by inputting
an angle value or keep aligned.
Process Mode: You can use a block reference to break

|LJ [ Browse... ] [ Pick ]

Rotation

Angle: [¥] Aligned

Process mode

[¥] Break [7] Shelter

[¥] Uniform Scale

[ insett block | [ Selectinsetted block | [ Cancel |

or wipeout objects when overlapping.




Block Break Process Mode lllustration
Break: Breaks background object(s) when a block reference is overlapped.
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Wipeout: Wipeout background object(s) when a block reference is overlapped.

Y
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710, Model  Layoutl | Layout2 /
Replace Block with Another Block: In the current drawing, you can use o
one block to replace another one, moreover, you can purge the
unreferenced block when the operation is finished.
Menu: Expresstools>Blocks>ReplaceBlock

Command Entry: BLOCKREPLACE

Select a block to replace: Double bed. Then select: OK [ Select a block to replace
Select the block to be replaced: Sofa. Then select: OK Sofa 1
FPurge unreferenced items when finished? Yes/No

[ Picke | Doublebed1

| ok [ cancel

Select the block to be replacedDouble bed

Double bed 1

See the result below:
DOUBLE BED

Pick< Sofal




Copy Nested Objects: Copy objects in an xref or a block.

Menu: Express>Blocks>Copy Nested Objects
Command Entry: NCOPY

Command line prompts as follows:
Select nested objects to copy: Use an object selection method

Base point: Specify a point, or enter M for multiple copies
Specify second point or <use first point as displacement> Specify a point

Explode Atiribute to Text: Explode blocks, converting value of attributes to text objects.

Menu: Express>Blocks >Explode Attributes to Text
Command Entry: BURST

Command line prompts as follows: Select entities: Use an object selection method
For example: Explode attributes and convert them to text objects.

1. Select a block containing two attributes. 2. Block exploded and attribute values converted to text.

Iyl

Enter number {
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Attribute Increment: ATTING command helps to specify attribute of blocks with incremental value, and to modify attribute value
of blocks according to the sort method.

Menu: Express>Blocks > Atiribute Increment
Command Entry: ATTINC

This command can increase block attribute value that contains a number or letter. When ATTINC command is on, as long as the
drawing is not closed, when copying, inserting and deleting a block attribute in the drawing, the property number or letter can
be updated automatically.
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Export Attribute Information: Export block attribute to an external file in tab-delimited ASCII format.

Menu: Express>Blocks>Export Attribute Information
Command Entry: ATTOUT

Once performed ATTOUT command, specify file name and save path in "Enter output filename" dialog box, then command line
prompts: Select entities. Specify the blocks whose attributes you want to export.

The block names and attributes are exported to the ——

named file. If the file already exists, you are D Enter number
prompted before it is overwritten. You can easily — [ 1238668944
view attributes in a spreadsheet format and edit
individual attribute values. Then you can enter the
new values into the drawing file, using the ATTIN ]
command. L ‘

Import Attribute Information: Import block attribute to an external file in tab-delimited ASCII format.

Menu: Express>Blocks>Import Attribute Information
Command Entry: ATTIN

Using ATTIN and ATTOUT together, you can quickly make changes to attribute values for selected block references.

Once this command is performed, Gl S5 L siitarois

the "Enter input filename" dialog T e —— Cafl
will pop up for the user to search 1238668944 [| mowes | ‘ =

file, import the block attributes ‘i?ff'w”;ii;f"““a "? s

along with the same handle and o B -

block name into the drawing, and B

make changes to the block % e —— — -
attributes as well. e ()




Once an attribute value is modified, it will be integrated into the specified block. It should be noticed that the imported file can't
be attribute file exported by ATTOUT command, whereas the file format should be identical to that of ATTOUT command
exporting.

Reads through imported file and processes each line when performing ATTIN command. If the block with the same handle and
name is found in the process of treating lines, the modified attribute value of this block will be applied. If several blocks with
the same handle and name are found, then system prompts whether to interactively assign saving data when processing these
blocks. If "Yes" is selected, the data of each command line will be listed enabling selection of a block to apply this attribute.
Press ENTER to skip to next line, press ESC to exit.

Edit Block Attribute in Place: Allows you to edit the textual contents of an attribute of a block when you feel like editing the
attribute values without accessing the attribute editor.

Menu: Express>Blocks>Edit Block Attribute in Place
Command Entry: ATTIPEDIT

Statistics Blocks Number: You can statistics the quantity of various blocks through this function.

Menu: Express>Blocks> Statistics Blocks Number
Command Entry: BLKNUM

Once this command is performed, its dialog box will pop up. Under Stat. Condition, you can input a block name, layer or check
the options: Ignore the blocks in the same insert point and also ignore the scale.

§ Stat. Block quantity @

Stat. Condition:
Black Name lTV

[ Layer I—l i‘

Ignore the blocks in the same

insert point.
[¥] lgnore scale<= [1.0 \ Blocks
I:] 3 |Blocks
X FLIP DOOR




Menu: Express>Blocks> Count Blocks
Command Entry: BCOUNT

Operation steps:

1. Start the command, the command line
prompts “Enter to select all blocks or ...".
2. You can press enter to select all the

blocks within the drawing or by selecting Iﬁ —

X ot

blocks.
3. Once pressing “Enter” the system will display the result in the command line.

Change Block Color: Modify the block color quickly.

Menu: Express>Blocks>Change Block Color

Command Entry: bChgCol @ @
Operation steps:

1. Start the command.

2. Input new color number, here we input 30 for example.

3. Select block objects, for which the color needs to be changed. : T — %
4. Finished modifying.

Change Block Linewidth: This function can modify block linewidth quickly.

Menu: Express>Blocks>Change Block Linewidth
Command Entry: bChgWid

Operation steps:

1. Start the command.

2. Input a new line width value.

3. Select block objects, for which the line widths need to be changed.
4. Finish changing the line width.

Change Block Text Angle: This function can change the text rotation angle of the block and it only takes effect on text or mtext,
attribute text can’t be changed.

Menu: Express>Blocks>Change Block Text Angle @
Command Entry: bChgAng o - C} P\

5\

Yy
Operation steps: 66

1. Start the command.
2. Input new text angle(comparative with @) <0> input 0.

3. Select the block to change text angle. then Select objects: G S ‘t Q. C ,/—\ D
4. Finish changing the text angle.




Change Block Text High: This function can change the height of the block, it only takes effect on text or mtext, attribute text
can't be changed.

Menu: Express>Blocks>Change Block Text High
Command Entry: bChgHei

GstarCAD

Operation steps:
1. Start the command.

2. Input a new text height value.
3. Select objects whose text heights need to be changed. G S At Q V\ [: A D

4. Enter to finish the command.

Change Block Layer: This function can change the
block layer.

Menu: Express>Blocks>Change Block Layer
Command Entry: bChglay

Operation steps:

1. Start the command.

2. Input target layer name.

3. Select block objects to change layer.
4. Press Enter. If the target layer exists, the selected block will be moved to the target layer, if a target does not exist, the
software will make a new layer automatically and move the block object to the new layer.

Convert BLOCK to XREF: Replace all instances of a standard u P .
block with an xref. Unbind xrefs that are bound. X \&4 s

Menu: Express>Blocks>Convert Block to Xref
Command Entry: BLOCKTOXREF .

-BLOCKTOXREF searches the entire drawing for references to a specified block name and replaces them with an xref that you
specify. You can have the unreferenced block purged when done. In BLOCKTOXREF dialog box. Select a block to replace: Table
and 4 chairs. Then select OK button.

-In Select a Xref file. Select the Xref you want. Then
select Open button.
Purge unreferenced items when finished? Yes/No




List Xref/Block Properties: List the type, block name, layer name, color and linetype of a nested object in a block or an xref.

Menu: Express>Blocks> List Xref/Block Properties
Command Entry: XLIST

Command line prompts as follow: Select nested xref or block object to list: Use an
object selection method. After selecting an external reference, the "Xref/Block object"
dialog box will display attributes of specified blocks and xref, including object type,
block name, color and linetype.

Object: LINE
r

Color: Bylay
Linetype : Continuous

=]

Trim to Nested Objects: Trims objects with a block as a cutting boundary.

Menu: Express>Blocks>Trim to Nested Objects
Command Entry: BTRIM

Command line prompts as follow:

-Select objects or <select all>. Select one or
more blocks and press ENTER.

-Select the object to Trim or Shift-select to Extend
or [Edge/Fence/Crossing/Project]: Select object(s)
or enter an option and press ENTER.

Extend to Nested Objects: Extends objects such as line segment, arc, polyline or ray to a block. Objects would be extended to a
block as close as possible if they cannot intersect with each other.

Menu: Express>Blocks>Extend to Nested Objects
Command Entry: BEXTEND

Command line prompts as follow:

-Select objects or <select all>. Select one or more
blocks and press ENTER.

-Select the object to Extend or Shift-select to Trim or
[Edge/Fence/Crossing/Project]: Select object(s) or
enter an option and press ENTER.

External Reference Relocate: With this function, our software can

recognize the reference in the drawing and give you the reference pebrecs e
state, if you want to select another reference path, click the

“Relocate” button and the reference will be displayed in the
drawing again.

Path state
C:\Documents and Settings\Administrat...  Located

Menu: Express>Blocks>External Reference Relocate
Command Entry: CHGXREFPATHa < |

[HelalivePath] [ Relocate J [ Exit ]

10



Operation steps:

1. Start the command and a dialog box will pop up.

2. Select the external reference name which you want to modify.

3. If you click the “Relative Path” button, you will get a relative path of the reference; If you click “Relocate” button, the system
will relocate the external reference.

11



2. TextTools

Justify Text: Change a text object's justification without changing its position. Works with text, mtext, and attribute definition
objects.

Menu: Express > Text Tools > Justify Text
Command Entry: TJUST

Select objects: Use an object selection method.
[Start/Center/Middle/Right/TL/TC/TRIML/MC/MR/BL/BC/BR] <Start>: Choose the new justification

Usage Example: Covert text to middle justified

-Text left justified. -Text after justification change.
TEXTOUTLINE  ~ " TEXTOUTLINE
EXPLODE EXPLODE

Rotate Text: Aligns text, mtext and block attribute objects to new orientation. Rotates text, mtext, and attribute definition objects
so that they end up being as close as possible to horizontal or right-read (similar to the behavior of dimension text). Objects are
rotated about their middle point in 180-degree increments. For example, if the text is upside-down, it becomes right-side up
after a TORIENT operation. Similarly, left-read text becomes right-read text.

Menu: Express > Text Tools > Rotate Text
Command Entry: TORIENT

*
2
k> ‘Z &
. . , s ‘_e‘\ 2 .o,@ @t This 10 9cthid®8 text
-Select objects: Use an object selection method L %, erR e ® This et This & text
~New absolue rofation <0:Enter a new absolute orientation angle % * *4§ »;5';3 B e text T s text
. . = e o
for all selected text. Usage Example: -Text before rotation (Fig 3) & [ b ¥ oy, This is text  This is text
. i . @ This ja. telhig i text
~Text after rotation specified angle of 0 degrees (Fig 4) £ 5 % ® his"E et

Change Text Style: This function can change current text style for specified text and single line text, multiline texts are available.

Menu: Express > Text Tools > Change Text Style
Command Entry: CHGSTY

Operation steps: . * -TeX t

1. Start the command.

2. Select the text to change text style and you can modify several b b ek e 54 A
objects at a time. Then Press enter to finish the command. WEE Specty opposte cumer.

12



Chinese Characters Split: This function can split single line texts to single text one by one, because the English word is a
combination of several letters, this function only make sense for Chinese Characters.

Menu: Express > Text Tools > Chinese Characters Split Command Entry: HZCF

1. Start the command. m -%-

2. Select the text to be split.
Command. _HZCF
3. Press enter to finish splitting. T e

ICommand. <[ r

Operation steps:

Character Break:  Menu: Express > Text Tools > Character Break Command Entry: WZDD

Operation steps:
1. Start the command. 2. Select the text to break. 3. Specify the position for the break.

Change Character: This function can continuously revise multiple text objects, single line and Mtext are applicable.

Menu: Express > Text Tools > Change Character
Command Entry: DDEDIT

Operation steps:

Texx

1. Start the command. e
2. Select the text to be replaced. Ponrant, DOEDIT

Select an annotation object or [Undo]. _
3. Input characters to replace and press Enter to finish. Select an snotation cbject o [Undo]

Change One Character: This function can change texts in selected single line texts, you can just input characters to be replaced
and characters to replace according to the prompts, Moreover it can be used in several single line texts at the same time.

Menu: Express > Text Tools > Change One Character ~ Command Entry: CHGTXT

Operation steps:
1. Start the command. eX

2. Select the text to be replaced. Command Line

: CHGTXT
3. Input the characters to be replaced. %;mmmm
4. Input characters to replace. e, Spechyopposte comer: 1found
.. input the characters to be replaced-ext
5. Press enter to finish. oyt chewaetens to reriaceel
Changed 1 rows.

13



Change Text Height/Width/Angle/Position: This function is used to modify text height, text width, text angle and text position.
You can click or select characters by window selection.

Menu: Express > Text Tools > Change Text Height/Width/Angle/Position
Command Entry: TXTHEI / TXTWID / TXTANG / TXTPOS

Delete Annotation: This function is based on this kind of circumstance, you can select one text annotation to be deleted , the
software will register all the annotations in one layer, you can just press enter and all the text annotations will be deleted or you
can select the texts by window selection and it will not affect the texts of other layers.

Menu: Express > Text Tools > Delete Annotation
Command Entry: WZOFF

Operation steps:

1. Start the command.

2. Specify a text annotation to be deleted. At this time you only specify the operation layer, if you directly press enter, the entire
layer single texts will be deleted.

3. Select annotations to be deleted (you can select several objects by window selection) and press enter to finish.

Adjust Character: When the texts are mixed with Chinese characters, English letters and Arabic numerals, the text height will be
different and the visual effect is not good. You can use this function to match the text height, but this function will explode the
text's and it will be difficult to re-edit, so we suggest using this function after the user finished editing the drawing.

Menu: Express > Text Tools > Adjust Character GSta rCAD
Command Entry: TTL2 -
GstarCAD

Model / Layoutl / Layout2

—
PdiCommand: TTL2

Operation steps:
1. Start the command.

2. Select the text object which needs to adjust the height. * ;:;e:ft object to need repair the charster high -
3. Press enter to finish. Conmand:

1465.2982, 587.3208, 0

14



3. Layout Tools

Align Space: Adjust the zoom and pan factor of in the layout viewport based on the alignment points specified in the model
space and paper space.

Menu: Express > Layout Tools> Align Space

Command Entry: ALIGNSPACE

List Viewport Scale: Displays the scale of the current viewport or of a selected layout viewport.
Menu: Express > Layout Tools> List Viewport Scale
Command Entry: VPSCALE

Synchronize Viewports: Synchronize one or more layout viewports to a master layout viewport to have the exact locations
matched up. All synchronized viewports use the zoom factor of the master viewport.

Menu: Express > Layout Tools> Synchronize Viewports

Command Entry: VPSYNC

Layout Merge: Merges specific layouts into a single layout. All layouts or model are available to be picked, and you can specify
an existing layout or enter a new name to create a new layout as the destination layout.

Menu: Express > Layout Tools> Layout Merge
Command Entry: LAYOUTMERGE

15



4,  Dimension Tools

Area Table: AREATABLE command automatically dimension and count the area of anenclosed object and export the result to a
table in the current drawing area.

Menu: Express>Dimension>AreaTable
Command Entry: AREATABLE

The enclosed area or object can be marked with a number or area symbol, and the area table data can be generated at the same
time. The area data can be exported to a text or table file. The values in the table can be changed automatically when the
number or area size is changed.

i E 9 Cioud  Appliction  teip (LY
EEEEEEE @~ H R
AR -T- | o = - P
AN & <k ol =8 & i )
Change Incremental _Stafistics Texton | Block Attribute Count | Ares  Export Coordinate | Break Super ChangeZ ic Drawin:
Text Copy  Summa stion ine Break Increment Blocks Table Coordinate Point Object Hatch Coordinate | Compare Compare ce
Modify
(1 G AreaTable
=
Border Output
[ Pickpoint [“File output

%| selecronect C:\Users\win 10\Desktop\AREA TABLE.tet |,

Text Settings
®omarea

Text Style:
Text Height:

Text Location:

Start Number:

Area Prefic:

O oim Number

Standard v

Area Suffix:

Number Prefix:

Number Suffix:

m:

LA

Table Settings
Create Table
Assodiate Number
Calaulate Sum Area
Table Style:
Title:
First Header:

Second Header:

Transform Units

Units From:

Units To: Sauare

Ratio: 1000 :

Standard v

Area Table

Square millmeters

meters

Area Table

Number

Area

7

7.104m2

2

13.806m2

Sum area

20.910m2

Rapid Dist: Measures distance and angle between 2D objects along X, Y axis rapidly by moving mouse.

Menu: Express>Dimension> Rapid Dist

Command Entry: RAPIDDIST

Distances that only can be measured along X, Y axis
based on the position of your mouse, are displayed
dynamically as you move your mouse over and
between objects. Angles between the objects touched
by distance lines, are displayed dynamically at the

same time.

The command only can be used under WCS, and only
measure the 2D objects. And the angles of the blocks

can't be measured.

16




Type “Settings”, you can set unit conversion and scale in & Settings y

setting window.
Scale Annotation  Scale :

Type “Record”, You can save the current result in command line ———— ———

. Unit Units From cm ~ Convert To finch ~
window,

which is convenient to check or copy data to other documents.

Change Dimension Text: Change the dimension content into the specified value.

Menu: Express>Dimension>Change Dimension Text
Command Entry: CHGDIMTXT

() 90

Command line prompts as follows:

-Select dimension objects: Select a dimension

-Currently label content <129.9>, input new dimension text <practically
measure dimension=>. Type a new value (130)

Change Dimstyle: Apply the current dimension style
to the dimensions in the drawing.

Menu: Express>Dimension>Change Dimstyle
Command Entry: Dimstyle

130

Reset Dim Text Value: Restore a measurement value to overridden or s ol

modified dimension text. /:”\\\ £ // \\\ \\ /‘: \\:\
3 {\‘ J/ /" ( ‘\\ J ] (\ (\\ y ) //

Menu: Express>Dimension>Reset Dim Text Value L // /N

Command Entry: DIMREASSOC \\‘\\J;s\ e

Command line prompts as follows: Se/ect object: Select dimension =

objects with non-associative text or press ENTER to quit. 12122 3

17



Update Dimension: Updates any other dimension(s) to the current dimension style you want to apply.
Menu: Express>Dimension>Update Dimension Command Entry: DIMUPDATE

Command line prompts as follow:
-Select a dimension for standard: Select a dimension as a base.
-Select a dimension, ensure update the dimension style: Select dimension(s) to be update.

\

\R0.8877
Dimension
Standard

Dimension to be
Updated

Dimstyle Export: Exports named dimension styles and their settings to an external file.

Menu: Express>Dimension>Dimstyle Export | % |
. Export Filename
Command Entry: DIMEX EEE —
| Available Dimension Styles
Standard

Export Filename: Creates a DIM file. Enter the DIM file name or select Browse to locate the
file. If the file does not exist, it is created. If the file does exist, a prompt requests permission e

to overwrite. The new file is an ASCII file. ‘ii:ﬁse:'esz;"::;:;m
Available Dimension Styles. Selects the dimension styles to write to the ASCII file. The current

dimension styles are displayed. Each selected style is written to the file indicated in the Export Filename group.
Text Style Options. Saves either the dimension's Full Text Style
Information or the Text Style Name Only to the ASCII file.

Executing this command, starts the following dialog box: ‘

Note: Dimstyles are created and saved with the DDIM command. You
must select at least one Dimstyle for the export to be successful.

Dimstyle Import: Imports named dimension styles from a DIM file into the current drawing.

Menu: Express>Dimension>Dimstyle Import
Command Entry: DIMIM

Executing this command, starts the following dialog box:

18



Import Filename: Names the file you want
to import. Enter an existing file name or
select Browse to specify a DIM file to
import. The file must be of the form
generated by the corresponding DIMEX
command. All dimension styles in the
selected file are imported into the current
drawing. Text styles are also imported.

Import Options: Includes Keep the Existing Style, to keep the dimension style in the current drawing and Overwrite Existing
Style, to overwrite styles in the current drawing. The Keep the Existing Style option ignores the similarly named style being
imported; Overwrite Existing Style uses the similarly named style being imported.

Attach Leader to Annotation: Attach leader line to Mtext, tolerance, or block reference

object.
Use the QLATTACH

command to attach
Menu: Express>Dimension>Attach Leader to Annotation leaders to Mtext

Command Entry: QLATTACH

-Select Leader: Select a leader / /
-Select a dimension: Select the Mtext, tolerance, or block reference object for the

annotation.

Usage Example:

-Select a leader, and then specify the Mtext object to attach.
-Separate leader line and Mtext objects.

-Leader line with mtext attached as one object.

At the Select Leader: prompt, you will be prompted until you select a leader object or abort the command.
At the Select Annotation: prompt, you will be prompted until you select an MText, Tolerance, or Block Reference object for the
annotation.

Detach Leaders from Annotation: Detach leader line from mtext, tolerance, or block reference object.

Menu: Express>Dimension>Detach Leaders from Annotation Command Entry: QLDETACHSET

-Select objects: Select leader line.
WITHOUT Leader line

Leader line
Usage Example:

-Select a leader line to detach from an mtext object.

19



Global Attach Leader to Annotation: Globally attaches leaders line to mtext, tolerance, or block reference objects.
Menu; Express>Dimension>Global Attach Leader to Annotation  Command Entry: QLATTACHSET

-Select objects: Select one or multiple leader lines and annotation objects.

MTEXT
Usage Example:
-Select leader line(s), and mtext objects to attach.

-Select objects: Select one or multiple leader lines and annotation objects,
the command line prompts: Number of unlocked leaders = 2, Number with
annotation detached = 2

-Leader with detached Mtext object (Fig 5)

-Leader attached to block object (Fig 6)

20



5. Selection Tools
Get Selection Set: Create a temporary selection set of objects.
Menu: Express>Selection>Get Selection Set  Command Entry: GETSEL

-Select an object on the Source layer: Use a selection set method or press ENTER for all layers.
-Select an object of the Type you want: Use a selection set method or press ENTER for all object types.

Fast Select: Selects the object that touches the specifide object.
Menu: Express>Selection> Fast Select Command Entry: FASTSEL

You can input FASTSEL command to select all objects that touch the selected object immediately.

Command Line

Command: [FiyE=8

Use 'FSMODE to contreol chain selection.
FSMODE = ON. W
Select touching object: < >

Supported objects include: Lines, polylines, circles, arcs, attribute definitions, text, Mtext, ellipses, and images.
FSMODE: Controls two behaviors of FASTSEL command, default valug is OFF.

If FSMODE is turned OFF, when you execute the FASTSEL command, it selects only those objects that are touching the
selected object.

If FSMODE is turned ON, when you execute the FASTSEL command, it selects all the objects that are touching the selected
object, as well as any objects that are touching those objects. The selection process of all unselected touching objects
continues until there are no more unselected objects visible in the drawing area.

Filtrate Selection Select, edit, and name filters for object selection.

Menu: Express>Selection> Filtrate Selection Command Entry: Filter

Select Object Filter dialog box Options:

1.X Y Z Parameters: Defines drawing. Select the items to ——
additional filter parameters depending filter. . ‘ ;
on the object. In the filter parameters, 3. Add to List: Adds the ) (o= Sitlen | Do s
you can use relative operators such as current Select Filter property : mmd -
< (less than) or > (greater than). to the filter list. Filter —
2. Select: Displays a dialog box listing properties that you add to (o] [om) o)
all items of the specified type in the the unnamed filter remain

21



available during the current work
session unless you manually delete
them.

4. Replace: Replaces the filter
property selected in the filter property
list with the one displayed in Select
Filter.

5. Add Selected Object: Adds one
selected object in the drawing to the
filter list.

6. Edit ltem: Moves the selected filter
property into the Select Filter area for
editing. To edit a filter property, select
itand choose Edit Item. Edit the filter

property and choose Substitute. The
edited filter replaces the selected filter
property.

7. Delete: Deletes a selected filter
property from the current filter.

8. Clear List: Deletes all the listed
properties from the current filter.

9. The filter name is used: Displays,
saves, and deletes filters.

10. Current: Displays saved filters.
Select a filter list to make it current.
The named filter and its list of
properties are loaded from the default

Get Selection by Block Name: You can use this function to multi-select objects

with the same name in specified area.

Menu: Express>Selection Tools> Get Selection by Block Name

Command Entry: GETBLKSEL

Operation steps:
1. Start the command.

2. Select object, specify a block name for operation.

3. Specify the region.

file, filter.nfl

11. Save As: Saves a filter and its list
of properties. The filter is saved in the
filter.nfl file. Names can contain up to
18 characters.

12. Delete Current Filter List: Deletes a
filter and all its properties from the
default filter file.

13. Apply: Exits the dialog box and
displays the Select Objects prompt,
where you create a selection set. The
current filter is used on the objects
you select.

Flease select Ertty Ctject 1 Ertiies have been selected
[lease select Etty Otject 1 Erties have been selected
1 erttis have been ttered

4. System will bring all the blocks with same name in region selected area into the selection.

Get Selection by Object Type: You can use this function to multi-select
objects with the same entity type in specified area.

Menu: Express>Selection Tools>Get Selection by Object Type

Command Entry: GETENTSEL
Operation steps:

e

1. Start the command. et gt

[Select objects with windows:<Enter for select all>

[Please select Entity Object:

|Please input the sencond comer: 92 Ertities have been selected
85 ertities have been fitered

2. Select object and system will take the specified entity type as target

type. Then specify region. . e
3. System will bring all the blocks with same entity type in region
selected area into the selection.
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Get Selection by Layer: You can use this function to select all the objects in specified layer and specified region at one time.

Menu: Express>Selection Tools>Get Selection by Layer

Command Entry: GETLAYSEL

Operation steps:

1. Start the command.

2. Specify an entity which is in the target layer, then specify region.
3. System will select all the objects in specified layer and specified
region.

Get Selection by Color: Quick select the objects with the same color.

Menu: Express> Selection Tools > Get Selection by Color

Command Entry: GETCOLSEL

Operation steps:

1. Start the command.

2. Select one object and system will take the object’s color as target color.

3. Specify region.

4. System will select the objects which have the same color as the target object automatically.
Get Selection by Object/Layer: Select entities by entity type and layer.

Menu: Express> Selection Tools> Get Selection by Object/Layer

Command Entry: GETENTLAYSEL

Operation steps:

1. Start the command.

2. Select one object and system will take the object layer as target layer.

3. Specify region.

4, System will select the objects which are in the same layer and with same entity type automatically.

Get Selection by Object/Color: Select entities by entity type and color.

Menu: Express > Selection Tools > Get Selection by Object/Color

Command Entry: GETENTCOLSEL

Operation steps:

1. Start the command.

2. Select one object and system will take the object’s color as target color.

3. Specify region.

4. System will select the objects which have the same entity type and color as the target object automatically.
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Get Selection by Layer/Color: Select entities by color and layer.

Menu: Express>Selection Tools>Get Selection by Layer/Color

Command Entry: GETLAYCOLSEL

Operation steps:

1. Start the command.

2. Specify an entity which is in the target layer.

3. Specify region.

4. System will select the objects which have the same color and same layer as the target object automatically.
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6. Modify Tools

Layer List Layers to Adjust Draw Order

Layer Draworder: Rearranges the layer order to adjust the

sequence of the objects. T
++ 4+

Menu: Express>Modify> Layer Draworder Command m i

Entry: LAYDRAWORDER -

Mame: [ | Bring to Front Send to Back

Draworder by Color: Arranges the drawing order of selected objects by their color number.

Menu: Express>Modify> Draworder by Color Command Entry: CDORDER

Break Object: In some industrial application design, ..., . U B eg » I N
. . . . rerury < > i L SUPPLY
sometimes we need to break pipes or cable lines in our

schematic drawing to indicate their spatial relationship.
Sometimes we also need to break lines at crossing point to
make it convenient for the later edit. Break Object tool
came from this kind of needs.

BACKFLOW

® (K PrevenTion
Ly, 3%
o

COLD WATER

BOILER MAKE UP

Menu: Express tools>Modify>Break Object
Command Entry: BREAKOBJECT

This tool provides four breaking modes with gap distance to visualize the differences between breaking options.

Gap. Indicates the gap value between broken objects
Break all objects selected with each other: This option breaks all intersected objects each other. You can select objects by
window selection or picking each object.

Break selected objects with other selected objects: |7 BreakObject (=)
This option breaks all intersected objects by two
selection sets (A and B). The objects selected Gap: | 100
under the first set (A) will be broken meanwhile e e

the objects selected under the second set (B) will

[ Break all objects selected with eatch other ]

be not broken. [ Break selected objects with other selected objects J
Break objects touching selected objects: This option

breaks all intersected objects that touch at first
instance selected object. [ Break selected objects with any objects that touch it |

[ Break objects touching selected objects ]

Break selected objects with any objects that touch it:
This option breaks the first instance selected

object with all intersected objects to it.
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Move/Copy/Rotate: Move, copy, rotate, and scales object(s) with a single command.

Menu: Express tools>Modify >Move/Copy/Rotate
Command Entry: MOCORO

Command line prompts as follow: Select objects: Select object(s) and press Enter
Base point: Specify a base point
[Move/Copy/Rotate/Scale/Base/Undo] <eXit>: Once an option is specified

/\@--

Options
Move: Move object(s). Copy: Make multiple copies of object(s). Rotate. Rotate object(s). Scale: Dynamically scale object(s).
Base: Specifies a base point for object(s) to be moved, copied, scaled or rotated.

Region Scale: You can select a region of a drawing to be cut and copied to a new location.

Menu: Express tools>Modify>Region Scale
Command Entry: REGSCALE

Command line prompts as follow:
Specify left up corner point for full-page proof: Select a region from left up to IHL‘\
—

right down corner |

O = DETAL

REMARKS

BOLTS, NUTS, WASHERS AND CIRCLIPS
SHALL BE BORNE BY THE MANUFACTURER
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Select the object to Trim or shift-select to Extend or [Edge/Fence/Crossing/Project]:
Select objects to trim or press Enter to finish the operation. ’

DETAIL

Input zoom scaling, the block and text will zoom together < Enter- No Zoom>: Press Enter to finish the
operation.

Trim Enhancement: Trim one side of an object which is intersecting with other objects. The object can be polyline, line, circle,
arc, ellipse, image or text.

Menu: Express tools>Modify>Trim Enhancement
Command Entry: EXTRIM

Operation steps:

1. Start the command.

2. Select an object as trim reference, here we select the rectangle for example.

3. Specify the side to trim on.

4. Here we select the internal point of the rectangle, you will see that the internal lines of the rectangle are trimmed.

Extended Offset: This enhanced version of the OFFSET command offers several advantages over the standard command,
including layer control, undo, and a multiple option.

Menu: Express tools>Modify > Extended Offset
Command Entry: EXOFFSET

1 Specify offset distance or [Through] <T=: Specify the offset distance or through point
2 .Select object(s) to offset or [Options/Undo]: Select an object to offset, change options or undo
3 .Specify an option to set [Distance/Layer/Gaplype]: Specify an option
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EXOFFSET Options:

Distance: Specify the offset distance or through point

Layer: Specify the layer for new objects. Current Layer or Source Object Layer

GapType. Sets or changes the offset mode as controlled by the OFFSETGAPTYPE variable. The options are: Normal, Fillet or
Chamfer.

7~ 7 77
/ Y
///’ £ / /
Normal / /" Fillet / / Chamfsr’ 4
/// / // b //
- 11 P / / K o [ s
~ T < ‘
s e[ N \\ Y
\f\\\m\\\

\ Re X \
CR T S O 8

N

Distance Layer GapType

Multiple Pedit: This command is almost the same as the standard command.

Menu: Express tools>Modify >Multiple Pedit
Command Entry: MPEDIT

1 .Start the command.
2. Select object
3 . Specify an option to set [Open/Close/Decurve/Fit/Linetype-mode/Spline/Width/eXit] <eXit>:

Example to close plines:
1 .Select object: select plines which you want to close.

% .

2 .[Open/Close/Decurve/Fit/Linetype-mode/Spline/Widih/eXit] <eXit>:Input keyword: C and enter.
3 . You will get the plines closed.
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Delete Duplicate Objects : This function can not only manage overlapped lines, circles, Plines linear objects etc, but can also
manage entire coincident blocks, texts, dimensions and regions .Moreover, remove does not simply mean delete, it judges by
layer, color, line type and many relevant attributes and can delete or connect coincident parts of 2D and 3D Plines, circles, arcs
and overlapping line parts. Using this option can not only delete redundancy objects, but can also avoid editing and printing
problems caused by overlapped objects.

Menu: Express tools > Modify > Delete Duplicate Objects
Command Entry: OVERKILL

Start the command and the command line prompts as follow: Select objects: Select the objects to be compared and deleted.
In the overkill dialog box, you can set-up the object comparison, comparison precision (distance between objects) and the
object type. After selecting the options according to your need, select OK.

i Ei Object Comparison Setting
| 7| Ignore Layers Comparision Precision: 0.000001

| Ignore LineType
7] Ignore Color
P LineWeight

®
®
"L\@ | Ignore PlotStyle

Object type(Lines Arcs and Plines) and overkil style

I | AN 7] Pines - Optimize segments withn pines
Ej Ejj ] Overlap - Combine co-inear objects that partially overiap
V]End to End - Combne co-inear cbjects when algned end to end
Block :
duplicated duplicated i
millimetrically | deleted [ \®
I

Multiple Copy: Copy multiple objects with Repeat, Array, Divide and Measure options.

Menu: Express tools>Modify >Multiple Copy
Command Entry: COPYM

Start the command and the command line prompts as follow: Select objects. Select the objects to be copied

Base point: Specify a base point

Second point or [Repeat (last)/Divide/Measure/Array (dynamic)/Undo] <exit>: Select a second point or any option

Options:

Repeat: Repeat the last copy using the same offset distance.

Divide: Linear divide option. Prompts for an additional point and the number of copies to make. Makes evenly spaced copies of
the selected objects between the base point and the second selected point

Repeat Divide
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Measure: Linear measure option. Prompts for an additional point and the distance between copies. Makes evenly spaced
copies at the specified distance between the base point and the second selected point.
Array: Displays the Array Options prompt.

Measure Array

Layout By Path: Unlike common array function, LayoutByPath distributes object copies along a path (curve) with a variety of
array options. Users can choose ra8ndom, division and measure options and array in different directions along the path.

Menu: Express tools>Modify > Layout by path Command Entry: Layouthbypath

For example, on mapping drawing, we can apply this
tool to array the discontinuous central axis of the road
or highway as shown in the picture:

LAYOUTBYPATH

After started the command Layoutbypath, a message will S I S—

V LAYOUTREGENCTRL

display in the command line> Please select the object (o = oo /
array: - e

/ o ’-‘-_‘,

After select the object, a prompt message will display:

Please specify the base point:

The base point is the point where you want to start doing array from
the object. We can select the low left end point of this object:

Endpoint foecify the base point.

After select base point of the object, a prompt message will display: .
Specify the object’s direction along the curve <Y axis of WCS>: : \ f N
This message is important because this will play with the object’s direction along Al

!
the path. Because we select the end low point of the object as base point, we have ik Lol g
as well i m!mbgsepoﬂ‘
to specify a parallel point direction to keep the object parallel along the path (long
green line): \

\
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After specify the object’s direction, a prompt message will

display:

Please select the curve: i
Then select the long green line. This line is the curve or path

[Please select the curve: [[FXTE]

that the object will follow.

After select the curve or path, a prompt message will display:
Specify select along which side of the curve <left side or forward
direction>: This
message is also important because we will specify the side which
the object will be array. For example, we specify left side of the
curve as shown in the picture.

After specify the side of the curve, a prompt message will display: Select the method Random (R) / Division (F) / Measure (D):

There are three options random, division and measure:

Random: This allows to array the selected object along the path in a specify point according to user’s need.
Division: This allows to array automatically the selected object along the path by inputting the number of objects.
Measure: This allows to array automatically the selected object along the path by inputting the distance value.

For example, if we do not know the distance between objects but we know the objects guantity, we can select the option
Division:

After select the option, a prompt message will display:
Enter the number: And we enter the value 11

After enter the value, a prompt message will display:

Pick a point on the curve as start point (Distribute from the
end curve when selection is empty):

Then pick one of the end points of the curve:

After pick the point of
the curve, you will get
accurate result: And
also you can repeat
the same array option
for the other blue
central axis of the
road.

Flatten Objects: Converts 3D geometry to a projected 2D representation.

Menu: Express>Modify> Flatten Objects Command Entry: Flatten
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7. Draw Tools

Superhatch: Fills an enclosed area or selected objects with a hatch pattern, solid fill or gradient hatch.

Menu: Express > Draw > Superhatch
Command Entry: Superhatch

The Superhatch dialog box is displayed:

Image: Accesses the Select Image dialog box to specify the image for the hatch pattern.
Block: Opens the Superhatch_Insert dialog box to specify the block for the hatch pattern.
Xref Attach: Accesses the Select reference file dialog box for specifying an xref file for a

hatch pattern.

WipeOut: Selects a wipeout object as a hatch pattern.

Select Existing. Selects an existing image, block, xref, or Wipeout as a hatch pattern.

For Images:

1. Open Superhatch dialog box.

2. Click Image... button, choose an image file, the
Superhatch Imageraster dialog box is displayed.
3. Pick the OK button in the Superhatch
Imageraster dialog box, specify insertion point,
scale factor and angle of rotation.

4. The prompt “Is the placement of this IMAGE
acceptable? [Yes/No] <yes>":

5. Pick a point in the rectangle, press ENTER to
finish.

For Blocks:

1. Open Superhatch dialog box.

2. Click the Block... button to access the
Superhatch_Insert dialog box:

Block: Click the Block... button to select a block in
the current file.

File: Pick the File... button to select a drawing file
as the block

Scale

— 43299214 _stadium

Position:

Options
Inserted point
Specify Parameters
On Soreen
x: [0.000000
y; [0-000000

2 | 0.000000

\_large_image Browse

F:\GSTARCAD\PRODUCT LINEVPLATFCRM\GSTARCAD PROTO

Scale angee
Spedify Parameters
OnSaeen

Angle:

Specify Parameters
©n Sareen

0.000000

Superhatch il M

=
Superhatch_Insert [ =] ~
Defined Blocks ==
Block .
Double bed 1 -
Pattern:
Double bed 1
Options
Spedfy Parameters On Screen
Insert Paint Scale Rotation
x. [0000000 | Loooo00 Angle: | 0.000000
v 0.000000 ¥ 1.000000
Selection; 'V EED
2. [0.000000 7 [ 1000000

3. Select the block in the Defined Blocks dialog box and press OK.

4. Specify insertion point, scale factor and angle of rotation.
5. The prompt “/s the placement of this IMAGE acceptable?
[Yes/No]<yes > "is displayed. Choose No to Esc. If you

choose Yes, GstarCAD will ask you to specify the first point

and the next point to place the image.

6. Specify an internal point of the objects for hatch boundary

Command Line.
ICommand: SUPERHATCH

i\ [insertEnter block name or [7] <NEW BED>: NEW BED
Unit: Millmeters convert: 1.0000
Specify insettion poirt or [Basepoirt/Scale/X/Y/Z/Rotate]:
Erter X scale factor, specify opposite comer, or [Comer/XYZ] <1: Enter ¥ sca
% e factor <use X scale factor>:
Specy rotation angle <O>:
Specify insetion point:
Enter X scale factor <1.000000:
please appoirt the rotate angle
Is the placement of this BLOCK acceptable? [Yes/No]<Yes>Y

please appoirt the first point
Command




then press ENTER to finish hatch

For WipeOut. . 1 I | Superhatch ==
1. Access Superhatch dialog box and nmllmllmm U

click the Wipeout button: <= 2

2. GstarCAD will ask you to specify %
insertion point to create an area that == :
maSkS underlylng ObJeCtS %I:]I|'||l|ﬁ|l||l‘|H|f|\|||II"lIIIII\II\HI e EIDEOUt

3. Press ENTER to finish creating the m

boundary that masks underlying objects.
4. As shown in the picture, move the new block to the carpet, the block will automatically cover
the object under it:

S !
= =
. B8
= =
= 3

AN TG e e e inie AN AN e e

Breakline Symbol; Creates a polyline and inserts the breakline symbol. The options within this command are provided to control
the relative size and appearance of the breakline symbol and an extension of the polyline beyond the selected start and end
points.

Menu: Express tools> Draw > Breakline Symbol

Command Entry: BREAKLINE
Structural Detail

Once start the command, the command line prompts as follow: {3606
Block = BRKLINE.DWG, Size = 1.000, Extension = 1.250 . Hsbddd
Specify first point for breakline or [Block/Size/Extension/sPecify line for L]
N o000
breakline]: Specify a point, or enter options - Structural Detail
Options: Fevee
Specily first point for breakline: Draws break line through specifying its S e9ee
start point and end point. — 10000

Structural Detail

Block: Determines the block to be used as the breakline symbol. E=ma s AN & Y
Enter the block name for breakline symbol <BRKLINE.DWG>: T & i e
Enter a block name and press ENTER or press ENTER. If you press Ereeee ﬁﬁm

10000
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ENTER directly, the saving path of the break symbol file will be displayed
on the command line.

Structural Detail

Seans

Size: Determines the size of the breakline symbol. - o000
Breakline symbol size < 1> Specify the size of the breakline symbol

10000

Extension. Determines the length of the line extension beyond selected )
Structural Detail

points. W
Breakline extension distance <1.25> Specify the extension distance. =] ¢ Q q.) Q)
Once the start point for the break line or the setup break symbol is 4 _._._._._._._._j.__‘___“_ ____________ A

assigned, the command line prompts as follows:
Specify second point for breakline: Specify a point

10000

Specify location for break symbol <Midpoint>. Specify the point on the
line segment to specify the location of the breakline symbol, or press ENTER to use the midpoint of the line.

Spline to Line: Converts spline(s) to numbers of straight lines.

Menu: Express tools>Draw> Spline to Line Command Entry: SPLINE2LINE

Once the command is started, the command line prompts as follow:

Select spline or [Set parameters(S)]: Select spline(s) or input “S” to set parameters

[The line precision/Starting point (S)<1.00>]: Input a new value bigger than 0 to join precision between segment lines
Conversion in a straight line to allow the greatest number of <5000>]: Input a new value smaller than 5000 to number of lings

At first, the system will fit the spline with a segment line which precision (Length) has been specified, if the line’s number
needed is more than the maximum number, the system will extend the length of the lings by force, using the maximum number
of lines to fit the spline.

Select spline or [Set parameters(S)]: Then select the spline(s) to be converted and press Enter to finish the operation

Spline to Pline: With this tool the SPline created can be converted to a polyline according to the accuracy (number of segments
of the arc) that the user assigns. The more specified the segment number is, the higher is the matching degree between the
converted Polyline.

Menu: Express tools>Draw>Spline to Pline Command Entry: SPTPL

For example, draw the follow spline sample with 5 arcs as shown:

5 ARCS IN THE SPLINE
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After the command SPTPL is started, Please select the object (Spline).

After selecting the object, a prompt message will be displayed > Delete . -

the spline? Yes(Y) / No(N). In this case, if we select Yes, this option will 3

delete the spline in place but if we select No, it will keep the spline. 6

After inputting the delete spline option, a prompt message will be .
displayed > Please enter the number of arcs Non-zero: And we have to 1 4 8

input a value higher than zero, for example 8. This value determings the 8 SEGMENTS CREATED IN THE PLINE
segment number of arcs to be created in the new Polyline.

Line to Pline: This function can convert one or multiple connected straight line(s), arc(s) to one polyline. You can access from:

Menu: Express tools>Draw>Line to Polyline
Command Entry: Line2pl

After starting the command, a
prompt message will be displayed>
Please enter the join precision: 0

The Join precision will determine

the union space between end

points of each object. In this case,
we will input value 0 to ensure the ‘
connection between objects (lines).

In this drawing there are many lines
\ AN
e

' A

After inputting the join value, Please select the objects to be joined and converted to Polyline:

\ In this drawing there are many lines

|
And finally, you have successfully created a polyline:

il
20 Polyfine

Calor ByLayer
Layer [
Linstype ByLayer

|

|
_%_m;______________________________________jm__

|
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8. Tools

Command Alias: This function allows users to add, modify, delete command alias and shell commands.

Menu: Express tools> Tools >Command Alias
Command Entry: ALIAS

Operation steps: " GstarCAD CommandAlias 1L .
File Edit Help 3 g
1. Start the command and a dialog box ey T y—
i starCAD commands entered from shortcut: T the ali d its ICAD d
i ” pop UD : ;n:sA & dsg(a,::Aod lomm:ndl IA add slj:iﬁz in:)atgisba;tels‘sbelow. i
2. Select commands to be deleted and B ooy 1 = P R
o ., ¥ 3DFACE |38 | f
click “Remove” button to delete Yy e GeaCAD
T AREA
command alias. oo, B B |
. ACADWBLO... WBLOCK "IDARRAY — @l
3. Select the command to be modified ADGENTER  ADCENTER 3DFACE =
AL ALIGN v 3DORBIT
and click “Edit” button, a dialog box will ¢ > ol
ADCENTER b))
pop up. (] Gontim chianges
4. Click “OK” to finish editing.

System Variable Editor:  Allows you to view, save, load and compare system variable settings.

Menu: Express tools> Tools > System Variable Editor
Command Entry: SYSVDLG

NewValue: |(Read-only]

PKSER Current Value:  p.0oon

System Variables Dialog Box Options: _VERNUM

ACISOUTVER = Initial Value:
ADCSTATE

AFLAGS SavedIn:  Not saved Type: Real
ANGBASE

L/SI‘ BOX Dlsplays a ||St 0]‘ System Va”ables The edlt fleld ﬁggg*ﬁ AREA is both a command and a system variable. The AREA system

variable stores the last area computed by the AREAcommand. Because
APERTURE entering area at the Command prompt invokes the AREA command,

above the list box allows for filtering the list box display s leslie SHIVAR it b e ssaifie 1E ey
based on user input. For example, entering DIM* in the ATIHEL:

AUNITS

edit field filters the list to display only system variables S
BACKZ Save All... “ Read... H Compare with saved “ 0K ][ Cancel ]
that start with DIM. If nothing is entered in the edit field, |EINDTYPE

the list displays all system variables. If more than one ;

system variable is highlighted, all edit and display options are unavailable.

New Value: Displays the current value Initial Value: Displays the initial value example, integer, real, string, and so

of the system variable highlighted in of the system variable highlighted in on.

the list box and allows you to edit that the list box. This is the value the

value. No changes are committed system variable has in a new drawing. Save All: Saves the current system

until the dialog is closed with the 0K variable settings to an SVF or SCR file.

button. Saved In: Displays where the value of SVF files can be read into SYSVDLG
the highlighted system variable is and SCR files are AutoCAD scripts

Current Value: Displays the value of saved. that can be run from the AutoCAD

the system variable highlighted in the command line. The button will display

list box as if SYSVDLG was started. Iype: Displays the type of the Save All, Save Selected or Save

highlighted system variable; for
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Filtered depending on the condition of drawing until you choose OK. All Compare with saved: Compares the

the system variable list. pending changes can be discarded variables of the drawing with the
with the Cancel button. SYSVDLG will saved SCR file.

Read: Restores saved settings from an validate new system variable values as

SVF file. No changes are saved to the they are changed.

Make Linetype: Creates a linetype based on selected objects.

ol AEFE

Menu: Express tools> Tools >Make Linetype
Command Entry: MKLTYPE Romds - T

(s Local Disk (O] |

s Local Disk (€ _

= Removable D Ricao

—  [@ICADISO
<

Once the command is started, the following window will be displayed. N
You can find the Line files (*.lin) and apply them to the current drawing. Fiepame:

Save as type: [Lin files ("Jin)

4 Hide Folders

Make Shape: Creates a shape definition based on selected objects.

Menu: Express tools> Tools>Make Shape Command Entry: MKLTYPE

Break Point Check: It can mark unclosed endpoints among selected lines, polylines or arcs, and close them immediately when
prompting that the area is not closed when hatching, calculating areas, or creating regions

Menu: Express tools> Tools>Break Point Check Command Entry: CLOSELINE
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9. Table Tools
Table Fill In: You can use this function to fill in the table or edit the texts.

Menu: Express>Table Tools>Table Fill In
Command Entry: FORMTXT

Operation steps:

1. Start the command. —
Text High Fashion: Just Fashion:

2. Click in the cell or input “Q” and a dialog box will pop up. Fiup TestHigh (45 JustSpace betweer: 40

3. In the dialog box you can set the text height fashion, just fashi ! Chanae Te Heh - Chanae Ter
g box you Xt heig ion, just fashion —

and other text attributes.
4. Click the blank area of a cell and input texts directly.
5. Enter to finish filling in.

Draw Table: This function can help you draw a table.

Menu: Express>Table Tools> Draw Table
Command Entry: BGE

Operation steps:

1. Start the command.

2. Specify the first point of the table.

3. The command line prompts.

a. Press Q key and the width of the form will increase a little, is used to adjust the horizontal width.
b. Press W key and the width of the form will decrease a little, used to adjust the horizontal width.
c. Press A key and the height of the form will increase a little, used to adjust the vertical height.

d. Press S key and the height of the form will decrease a little, used to adjust the vertical height.
4.You can input the corresponding options to adjust the size of the table.

5. Specify the second point to finish drawing the table.

Merge Cells: This function is similar to merge cells in Excel.

Menu: Express>Table Tools>Merge Cells
Command Entry: BGH

(Q)increase level width /(W)minish
t of form(cell width1s,cell hight,column13,row-13):

level width /(A)increase verticsl high /(S)minish vertical high /(D)input width and highspecify the second orientstion poin

Operation steps:

1. Start the command.
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2. Specify the borderline of the form to merge or the first cell, as shown below.
3. Merging effect as below. And press Enter to finish the command.

Samplel: Specify the borderline of the form

Sample2: Specify the first cell and another cell

[Specify the first point of the form {enter’:

Specify another cell:

Split Cells: This function is similar to split cells in Excel.

Menu: Express>Table Tools>Split Cells
Command Entry: BGFG

Operation steps:

1. Start the command.

2. Specify the cell which needs to be split.

3. Move the cursor, when the rows and columns are a size up.
click the mouse and the cell will be split automatically.

Add Bias: This function can add bias for a cell.

3 Column * 2 Row

Click the start and end point according to the prompts and the system will provide an intersection snap and can easily find the
start and end point of the bias, or you can click any area in one cell and the system will find the top left point of the cell
automatically, then the system will prompt you to select the end point, you can also click any area in the cell, system will take

the bottom right point as the end point automatically, this way, a bias is added in a cell.

Menu: Express>Table Tools>Add Bias
Command Entry: BGX

Operation steps:

1. Start the command.

2. Specify start point, you can click the top left point or click
the blank area in the cell.

3. Specify end point to finish drawing the bias.
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Drag Multiple Lines: You can change the row and column width by dragging the line of the table and the corresponding parts of
the line will also change. For example, drag the ling you selected to the right side and all the lines in the right side will move to
the right side correspondingly.

Menu: Express>Table Tools>Drag Multiple Lines
Command Entry: BGMT

Operation steps:

1. Start the command.

2. Specify the line of table for dragging.

3. Specify the place or distance to drag to (left is positive).
4. Enter to finish moving.

Drag Line: Different to Multiline drag, Drag line will just move the line you selected and other relevant lines will not move.

Menu: Express>Table Tools>Drag Line

Command Entry: BGST

Operation steps:

1.Start the command.

2.Specify the line of the table for dragging.

3.Specify the place or distance to drag to (left is positive).
4.Enter to finish the command.

Drag Segment: This command will not change the lines of the whole table, but just move the side line of a cell.

Menu: Express>Table Tools>Drag Segment
Command Entry: BGJT

Operation steps: ‘ 4
1. Start the command.
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2. Specify the line of the table for dragging
3. Specify the place or distance to drag (left is positive).
4. Enter to finish the command (Fig24).

Selection Scale: This function can zoom in and zoom out the whole table base on the point you specified.

Menu: Express>Table Tools> Selection Scale
Command Entry: BGSF

Operation steps:

1. Start the command and specify the base point for the line of table.

2. Move the cursor and the table will zoom.
3. Drag to a suitable position and click.

Intersection;e base point for the li:

Add Row: This function can add rows to the table.

Menu: Express>Table Tools>Add Row
Command Entry: BGZH

Operation steps:

1.Start the command.

2. Specify the position of the new row.

3. The system will add a row below the point you specified.

Add Column: This function can add new columns to the table.

Menu: Express>Table Tools>Add Column
Command Entry: BGZL

Operation steps:

1. Start the command.

2. Specify the direction of the new column.

3. The system will add a new column on the right side of the table.

4
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Delete Row: This function can delete the row of the table you specified.

Menu: Express>Table Tools>Delete Row

Command Entry: BGSH

Operation steps:

1. Start the command and specify the cell of row for delete.
2. The system will delete the row you specified.

Delete Column: This function can delete columns you specified.

Menu: Express>Table Tools>Delete Column
Command Entry: BGSL

Operation steps:

1. Start the command.

2. Specify the cell of column for delete.

3. The system will delete the column you specified.

Delete Table: This function can delete the table you selected.

Menu: Express>Table Tools>Delete Table
Command Entry: BGSC

Operation steps:
1. Start the command and specify the table for delete.
2. Enter to finish deleting.

|-

T T
Opposite corner: I "( 156°

Text Orientation Adjust: This function is used to adjust the alignment of the texts.

Menu: Express>Table Tools>Text Orientation Adjust
Command Entry: BGJS

Operation steps:

1. Start the command and select the text for adjust.
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GstorCAL GstorCAl GstorCAL

GstarCAL GstoarCAL GstarCAL

GstorCAll GstarCAL GstorCAL

Command Bar

Command: BGIS

*Text orientation adjust*-Bgjs
Select the text for adjust:

Select objects:Find out 1, total 1
Select objects:

Enter new justification...(® Center,1 Left,2 Right,3 Both)<flush center>:




2. Press Enter and the command line will prompt the location mode. 3. Here we input “1” to select left alignment.

4. The text you specified will align to the left, as shown below.

GstorCAl  GstoarCAIL GstarCAD

GstarCAL GstorCAL GstorCAL

GstorCAL GsterCA GstorCAL

Notice:

1. This function can only orient and adjust the table text in the TABLE layer.

2. The distance to the table line using left alignment or right alignment has already been set by the program, if you thunk that
the distance is not suitable, you can use the GstarCAD command to adjust the distance.

CAD Table to Excel: This command will convert sheets, composed by line/Spline and text/Mtext in CAD, to EXCEL.

Menu: Express>Table Tools> CAD Table to Excel

Command Entry: GC CTE .
et @ CAD Table to EXCEL [t

Operation method:
Table Scale: -‘I - | A4
1. Start the command and specify the conversion ratio.

2. Select the table that need to be changed and press enter, the system will
automatically open EXCEL after conversion.
3. Save the EXCEL sheet.

PART LIST C C
1 | o r e r i PARTUST

f
=
el

® GSTARCAD i CSTAREAD
* BMW CHASSIS CLAMP T 1 ; T TITE
— A?S.EMBLY | — :’ I 7 mw‘c:s:s:::uw
“BWMCP-10006394 | | .
. ‘
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10. Coordinate Tools
Export Coordinate: It is easier to extract coordinate data from dawing with COEXPORT innovative tool.

Menu: Express> Coordinate Tools>Export Coordinate
Command Entry: DIMCOORD

You can pick as many points as you need from your drawing and export all the coordinate data to .txt or .xIs file. This tool could
be applied conveniently on planning, surveying, mapping, and construction drawings.

Execute COEXPORT command and select what format (.txt/.xIs) you want to save the file.Then pick all the coordinate points on
your current drawing. Each time you pick a point, its data will be automatically storage in the file you selected. To finish the
process, press Enter. You can open the saved file and check out all coordinate data (X,Y,Z) extracted.

File name: Coordinate Data Analysis

Save as type: [‘st

Al v X
A
1 | X | Y z
2 4166.793 3581.064 0
3 4176.993 3596.544 0
4 4196.193 3632.784 0
5 4221512 3620.664 0
6 4216.473 3611.184 0
7 4241.552 3562.824 0
8 4244793 3552.624 0
9 4100.673 3519.264 0
4067.073 3553.104 0
4033.953 3540.264 0
4018.713 3551.304 0
4111473 3699.864 0
4129.713 3689.784 0
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Coordinate Point: Dimensions the point coordinate in the drawing.

Menu: Express>Coordinate Tools>Coordinate Point
Command Entry: DIMCOORD

SIEC

Current settings: Auto = On, Control = All, Combine = Yes, Layer = Yes
Current settings: Auto = On, Control = All, Combine = Yes, Layer = Yes
Current settings: Auto = Off, Control = All, Combine = Yes, Layer = Yes
finput dimension text scale<15.0>:5

finput dimension text high<8.0>:3

[Specify the coordinate point <Bxt>:

Unit: Unitless convest: 1.0000

[Enter attribute values

[Specify the coordinate direction Or [Change Parameter{Q)j<Enter>:
[Specify the coordinate peint Or [Change Parameter(Q)j<Bxit>:"Cancel™
Current settings: Auto = Off, Control = All, Combine = Yes, Layer = Yes
Current settings: Auto = Off, Control = All, Combine = Yes, Layer = Yes
Current settings: Auto = Off, Control = All, Combine = Yes, Layer = Yes

i

ICommand: 4 [ »

Change 7 Coordinate: Choose several objects at one time and then change

the Z coordinates together.

Menu: Express> Coordinate Tools>Change Z Coordinate _— ‘.454.‘.
Command Entry: CHANGEZ

Command: _CHANGEZ

[Select objects to change high <Enters:
[Select object: 1 found

[Select object

llnput new Z coordinate <0>:10

Command
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11. Drawing Tools

Graphic Compare: As we know the drawing compare function in GstarCAD can be used to compare similar drawings containing
nearly number of drawn objects to each other, especially to compare different versions of revision drawings.

TOCRIVE.Gwg 7 OCREVA dwg |

& DCEVAIng slars 'Dnmvw-s oo

Menu: Express tools>Drawing Tools>Graphic Compare ChirpareDiig ¥
Command Entry OCMP Old DWG: :\PLATFORM\GSTARCAD 2017\G17 FEATURES DWG\DCREVA.dwg

New DWG: F:\GSTARCADPRODUCT LINE|PLATFORMIGSTARCAD 2017\G17 F

CMP Result

Drawing compare can make comparisons between two similar [Z]Save raving

drawings (old DWG and New DWG) and generate them as separate R e
files. After pressing COMPARE button within CompareDwg dialog box, e ) [ ) [ s ]
the program will generate and open _old and _new.dwg files, where [ compar opon

you can see the differences between drawings. e o
Drawing Compare can find out differences (drawn objects) and show e Lk

the result with different colors, e.g. if a line is modified, removed or @line type. [@entinblock b

[

deleted added

== e
[@color [ font style I it modified

newly drawn, it will be displayed in different colors.

L. L

But there is something else that drawing compare

could not accomplish so accurately. Drawing compare  ~ .
can't insert and show the compared objects on the 7}717 171
current drawing working space that you are working at minly w kg | LI
real time. Besides, drawing compare can’'t show the ¥ :
details of how the objects were located before they L | - j S S
were modified. DC REVISION "A" DC REVISION "B"

So the details are very important when comparing

objects. Now the new and innovative Graphic Compare tool can do more! It does not only compare two drawingswith similar
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objects geometry and find out the differences but also display the details of any change at the current workspace of your
drawing in real time, e.g. if a line is modified, only the changed part of the line is displayed in different color. The unchanged
part remains unchanged.

Graphic compare dialog box
You can invoke the Graphic Compare dialog box by tipping OCMP command at command line or by dynamic input.

. . . X . - Drawing Compare ==
Specify Drawing: Offerstwo options of drawing comparison Specky drawing

between select objects on your current drawing or specify | oo
files.
Select Objects: Offers two options of objects selection

[ Select base objects and base point \ ﬂ No object selected

[Seled compare objects and base pointJ ﬂ No object selected

() Spectify file
including their base points to be compared.
Select base objects and base point: This option allows select
all objects, including a basis point as a first selection set to

Output Drawing
be ComDHFEd @ Insert cumrent document ") Bxport to afile
Select compare objects and base point: This option allows ; P TR E——
select all objects, including a basis point as a second

. : . : o0 ] [ Goned | [ e |
selection set to be compared with the first selection set.
= Output Settings (=3

Specify File: Checkingthis option allows browse two drawing file to be e e
compared known as base and compare file. e [0 -

Color: [DYelka vI

Output Drawing: Offers two options of drawing compared output.

Linetype: [ Continuous v I

Objects only in the compare drawing

Insert current document: This option allows insert the compared set of Layer: o v

selected objects on the current workspace. Color: (HRed -
Linetype: [ Continuous v |

Export to a file: This option allows output the compared set of selected Eoradens chiects

objects to a drawing file. Layer: 0 -
Color: (MColor 8 -

Output setings: You can setup properties like layer, color and linetype for Linetype: [
all selected objects to be compared to enhance visual differences
between them.

Continuous v ]

[ ok ] [ cancel |

Inserting Compared Objects Set into Current Drawing

To insert compared objects set into current drawing, first select the Specty drawing
button Select base objects and base point. Then select allobjects as i
first selection set called base objects and specify a base point for the
base objects.Then select the button Select compare objects and base
point and repeat all previous process mentioned above.

I[ Select base objects and base point 1 35 objects selected I

lESeied compare objects and base poima 41 objects selected I
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e e 'l 4? €] Specify the base point: .2361,1142.7552
DC REVISION "A" DC REVISION "A"

Under Output Drawing, check the option Insert current document.  Output Drawing
If you want setup visual properties for the compared objects, Btesiet
click Output settings button. After that you can place the enamerd ol € e N o GG
compared objects set in a convenient point according your need.

O | [ Conesl | [ b ]
o-E-a Za e
[t e - g
-l = !::' = L
" Lo
s = /
- saa’ /
DC REVISION "A" DC REVISION "B" COMPARED

Drawing Compare: Drawing compare is an exclusive function in GstarCAD which is added according to the user’s requirement.
[t enhances collaboration by using color-coded displays to show items on a drawing that have been changed, added, or deleted
by other members of the design team. Changes to items such as styles, block attribute, object of block can also be tracked. The
program will analyze the differences between two drawings automatically. Then the differences will be marked with different
colors. Users can also set the marking color by clicking the “option” button.

Menu: Express tools>Drawing Tools>Drawing Compare

ey =]
Command Entry: CMP
Old DW&: D:\ORIGINAL DRAWING. dwg
New DWG: D:\MODIFIED DRAWING. dwg Browse
Once the command is started, the following window will be displayed: e
Result Path: | i1\, | [ Browse
Compre ] [Comon ] [Come |

48



In this window, you have to browse the old DWG
(original drawing) and the new DWG (drawing
modified). You can also assign a path to save the
compared drawing. Then select the button Option to
set-up the comparison parameters.

Mark color(dlick change)
Old DWG New DWG

| = BT
- modified modified

| no modified

Cmp Precision: 0.0001 v

Cmp detail
@] layer

[¥] plot width
[¥] color [¥] font style

[]line type  [¥]entin block

Q.0uY

After setting up the comparison parameters such as: | —— o
i i = Y o B
colors, layers, line type, etc. select Ok to confirm &
these parameters. Note: Pay attention to the mark color
because the deleted, modified and added objects will —
i ; i | | — Classroom
assume these into the compared drawing. Then select =1
the button Compare in the window below to compare E
i A
both drawings. ‘
C1521 L |
CI515_ iy ,
(i ) M o | wm |
Old DWG: D:\ORIGINAL DRAWING.dwg Browse
‘New DWG: D:\MODIFIED DRAWING.dwg Browse E) - > 3600 M0930
@ , < [—
Result ZLQ)H” U - 970 [ |
[] save Result =
R.EsuitPaﬂ‘:‘D:\‘\ H Erowse [
O
(oomme | [Loton | [ concl ] ' ! Teachers
D a7 Room
| I A331F
D
|
n
C1521
01515 o

(T T ST C2721

Drawing Lock: Process some objects or the entire drawing into an uneditable state, and add the function of setting a password
to lock the objects. The processed drawing can be browsed and printed, but cannot be decomposed or edited.

Menu: Express tools>Drawing Tools>Drawing Lock
Command Entry: LOCKUP

After enabling the LOCKUP command, follow prompts are displayed:

fodify

Layout

Objects will not be able to be modified after using this function, would you like to continue? [Yes(Y)/No(N)]: Confirms whether to

continue executing the command.
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Select Object: Selects objects that you want to lock in the drawing. If any of them is already locked, the “1 was on a locked layer”
prompt will be displayed in the command line.

Do you want (o create a password [Yes(Y)/No(N)]: Asks whether to add a password after locking objects.

Enter password. Inputs the password you set for the locked objects.

Note:
e The locked objects can be selected as trim boundaries to unlocked s

ObjECtS ‘ Block Reference
B Color Bylayer
o The locked objects are turned into a block reference, and displayed s [

on a temporary layer.

e  The locked objects can be select. A little lock mark displays when
you hover the cursor on a locked object.

e  When executing the ERASE command to delete the locked objects,
the delete command cannot be executed, and the “1 was on a locked
layer” prompt will be displayed in the command line.

e Versions that lower than GstarCAD 2023 may can not unlock the objects which locked with password.

Batch Purge (Batch Files Cleaning): This new function allows to batch purge the excess objects such as blocks, layers, line
type, dimension style or text style on several DWG files. The Batpurge tool doesn’t need to open files. It executes the command
of purge directly, which makes it run with very high efficiency. You can access it from:

Menu: Express>Drawing Tools>Batch Purge  Command Entry: Batpurge

After the command is started, a dialog box will be displayed. In this dialog box you can add, select, unselect, clean and start
purging objects within DWG files with the following options:
Add Files: Add one or more batch files from the selected

path.
Add Folder: Add DWG files from a selected folder.
Select All: Select all the DWG file lists at once.

Select None: Unselect all the DWG files at once. J,,:
Delete: Delete selected object(s) in the file list.
Clear: Clean all the DWG file lists at once. =T -

Start Purge. Starts purging the selected DWG file list. After
purging, GstarCAD will generate a notepad file where you can see the purge details.
Log: After the purge operation is finished, you can Login in to the created notepad file and see the batch purge detail record.

Move BAK: Changes the destination folder for drawing backup (BAK) files.

Menu: Express>Drawing Tools> Move BAK  Command Entry: MOVEBAK
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MOVEBAK command changes the destination folder for drawing backup (BAK) files. Once you specify a path, the drawing’s
BAK files is placed in that path after every save operation.

Enter new value for MOVEBAK, or for none <current setting>:
Entera . (period) for none or type the folder name

If you enter ".", the MOVEBAK folder name is cleared and new BAK files will be created in the original folder.
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12. AutoXIsTable

Create Table:  Menu: Express tools>AutoXIsTable>Create Table ~ Command Entry: CAOT AUTOXLSTABLE CREATE

Operation steps:

1. In the AutoXLSTable pull-down menu, click Create Table.

2. Create an Excel spreadsheet or open an existing Excel spreadsheet in
Excel.

3. Click Finish button in the AutoXIsTable pull-down menu in Excel.

4. Specify insertion point in GstarCAD.

LT insert

Help Express

Express

=4 ® &
= Drawing L

i & @ | compare il

-

/ " ‘“‘ O'r' 939;‘:1) Ar—1

¢
)
LR QR A re o AT :
o G A g | () baee s BZam sppapm| =™ B Jelx v x|
- [ = | = 4 A B¢ ) | E | F | 6 | H | 1
Drawnglowg ' 1
> PART LIST ABC- ASSEMBLY DRAWING REXROT
| 3 [ABC-REXROT 38 1 | CARBON STEEL
[ 4 [ABCREX- PT39 3 | CARBON STEEL
PART LIST ABC- ASSEMBLY DRAWING REXROT 5 |ABC-REX- PT40 1 | CARBON STEEL
ABCREXROT 38 1 | CARBONSTEEL T T 6 |ABC-REX- PT41 5 | CARBON STEEL
[ABCREX-PT35 | 3 | cameonSsTERL | 1 1 7 |ABCREX- PT42 7 | CARBON STEEL
ARG IO 1 | CARBONSTEEL 8 |ABCREX-PT43 3 | CARBON STEEL
ABCREX: P41 3 1 CARSOMSTERL |8 [ABCREX- PT24 2 | CARBON STEEL
::; ::: ::i i ::ﬁ: 2::: 10 | ABC-REX- PT45 10 | CARBON STEEL
ABCREX-PTa4 2 | CARBONSTEEL | T 11 |ABC-REX-TP321 7 MILD STEEL
[ABCREX-PTAS _ 10 | CARBONSTEEL | | I 12 [ABC-REX-TP322 4 | CARBON STEEL
::; ::x::;;; 7 MILD STEEL i 13 |ABC-REX-TP323 1 | CARBON STEEL
X 4 CARBON STEEL
ABCREXTP323 1 | CARBONSTEEL i: :gg::g?ig;; i 3:::%?&& GSTARCAD ABC-ASSEMBLY
rorrran T o GETARCAD ARCASSEMBLY 16 | DESCRIPTION | SERAL | QT | MATERIAL  [TREATMENT| OBS REXROT
[ABC-REX-TP325 1 CARBON STEEL DRAWING REXROT
DESCRIPTION SERWL ar MATERIAL TREATMENT o8s 17

Edit Table: Menu: Express tools> AutoXIsTable>Edit Table Command Entry: _CAOT_AUTOXLSTABLE_EDIT

Operation steps:

1. Click Edit Table.

2. Select a table created by AutoXIsTable in GstarCAD then the Excel file will
open.

-@ Edit table

A B c D E F G H 1
1
: 5 PART LIST ABC- ASSEMBLY DRAWING REXROT
3 [ABCREXROT 38 T Wilo sTeEL
4 [ABCREX- PT39 3 | ™D sTEEL
PART LIST ABC- ASSEMBLY DRAWING REXROT T 5 |ABC-REX- PT40 1 | miLD sTEEL
P 3 ToiCAREONSTEE. 6 |ABC-REX- PT41 5 | MILD STEEL
ABC.REX-PT38 3 | CARBONSTEEL 7 |ABC-REX- PT42 7 | M sTEEL
| ABC-REX- PT40 ] CARBONSTEEL 8 | ABC-REX- PT43 3 MILD STEEL
[ ABC-REX- PT41 5 | CARBONSTEEL 9 | ABC-REX- PT44 2 | MILD STEEL
i:g:: ';:; ; aizg:iit 10 | ABC-REX- PT45 10 | MILD STEEL
REX- B
B RECoE - CRBONEIEE 11 | ABC-REX-TP321 7 | M sTEEL
[ABCREXPT45 10 | CARBONSTEEL 12 | ABC-REX-TP322 4 | MILD STEEL
ABCREX-TP321 7 MILD STEEL 13 | ABC-REX-TP323 1 MILD STEEL
[ABCREXTP322 4 | CARBONSTEEL 14 | ABC-REX-TP324 1 | LD sTEEL
. GSTARCAD ABC-ASSEMBLY
ABCREX TP323 L ). IGARBONSIEEL 15 [ ABC-REX-TP325 1 MILD STEEL o REXROT
2:2’:51: i; i a‘;:gxf“ﬂ GSTARCAD ABC-ASSEMBLY 16 | DESCRIPTION | SERIAL | QT | MATERIAL | TREATMENT| O0BS
o Ll DRAWING REXROT
DESCRIPTION SERIAL ar MATERIAL TREATMENT OBS.
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Update Table: Update table whose original Excel spreadsheet was modified.

Menu: Express tools>AutoXIsTable>Update Table il iy
Command Entry: CAOT AUTOXLSTABLE UPDATETBL

Operation steps: s — e
1. Click Update table.

2. Select the table to update then the table will update
automatically according to the relevant Excel.

Home 30 layout  View  Manage  Export  Help

O - || &Move ORevove =Tim~ 2 | 8 B & ¥ & 8B § &
-/ — @ & - || Bcopy MMiror [ Fiet - 3 ||| KO

tine " Poine Cide A [N paude Elsale By & (BB B PRI BB | "
A B c D £ F G H 1 — — — —
B 4 Drawingldwg X
> PART LIST ABC- ASSEMBLY DRAWING REXROT
3 [ABCREXROT 38 1 | M STEEL PART LIST ABC- ASSEMBLY DRAWING REXROT
4 |ABC-REX- PT39 3 | MILD STEEL ABCREXROT 38 T | MIDSTEEL
5 |ABC-REX- PT40 1 | MIDSTEEL [ABC-REX- PT39 3 | muDsTEEL
6 |ABC-REX- PT41 5 | MILD STEEL [ABCREX- PT40 1|  MIDSTEEL
7 |ABC-REX- PT42 7 | MILD STEEL [ABCREX-PT41 5 | MILDSTEEL
8 |ABC-REX- PT43 3 | MILD STEEL ABGREX-PTd2 2 MILD STEFL
9 |ABC-REX- PTA4 2 | MILD STEEL ABCREX: PTds 5 .} MILDSTER
10 [ABC-REX- PT2S 10 | MILD STEEL ABCREX PTAS 2 | WMILDSTEEL
|ABC-REX- PT45 10 MILD STEEL
11 |ABC-REX-TP321 7 | MILD STEEL Pt o | MilDSTeEL
12 | ABC-REX-TP322 4 | MILD STEEL ABCREXTP322 2 | MILD STEEL
13 | ABC-REX-TP323 1 | M STEEL ABCREX-TP323 1 | MIDSTEEL
14 |ABC-REX-TP324 1 | ML STEEL GSTARCAD ABC-ASSEMBLY ABCREXTP324 1 | MIDSTEEL CSTARCAD AGCSSER G
15 | ABC-REX-TP325 1 | MID STEEL b REXROT [ABCREXTP325 1|  MIDSTEEL e
16 | DESCRIPTION SERIAL | QT MATERIAL _[TREATMENT| OBS DESCRIPTION SERIAL | QT MATERIAL _ | TREATMENT | OBS

Update All the Tables:

Menu: Express>AutoXIsTable>Update All the Tables Command
Entry: CAOT AUTOXLSTABLE UPDATEALLTBL

After executing this command, the system will update all the table objects created by “Create Table” command.

File Link Management: You can use this function to edit, manage the link relation between a table object and an external EXCEL
file.

Menu: Express>AutoXIsTable>File Link Management
Command Entry: CAOT_AUTOXLSTABLE MANAGELINK

Operation steps: (@ ocettine v S, e
1. Start the command.

File Name Sheet Selec... Date Saved Path Attach...

.
2. Select table object in the drawing and a dialog box will pop up. e B AERILEE. IR
3. Click the “Browse” button to open the file selection dialog box. e
4. Select an XLS file which needs to be connected with a table < '

Excel File At; Sheet Name; Selection Address.

object and click “OK”, then return to the Link Manager dialog box. T ————

5. You can use the “Attach”, “Delete” and “Update” button to
complete link related editing and management.

Browse ...
Cancel
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Path Settings: This function is used to set the path of an Excel file.

Menu: Express>AutoXIsTable>Path Settings
Command Entry: CAOT_AUTOXLSTABLE USINGPATH
Excel File Path sEtt'mi_

Please select excel file path:

Operation steps:
1. Start the command and a dialog box will pop up as below. ST R
2. In the dialog box, you can set the path pattern of the Excel file.

(71 Using Relative Path Default: same path as dwg

Selection Management: You can use this function to calculate objects length and area, when the length and area change, the
calculating data will update automatically.

Menu: Express>AutoXIsTable> Selection Management
Command Entry: CAOT_AUTOXLSTABLE SELECTION

Purpose: use the “Selection Management” function to calculate the area of a circle and a rectangle, when length and area
change, the calculating data will update automatically.

1. Draw a circle and a rectangle as below, use the “Create Table” function to create a table as below.

8 y@EE]
A B
1 OBJECTS AREA i
2 CIRCLE
3 RECTANGLE

a

T EEEEE
@ Selection Manager @ Selection Manager =

2. Start the “Selection Management” command and a
dialog box will pop up.

3. Input “CIRCLE” and click the “New Group” button. T
4. Select the circle.
5. Press enter, the “Selection Management” dialog box
will add a new item “CIRCLE”, as shown below. N
6. You can add a “RECTANGLE” item using the same ai B
operation as above.

7. Click “Close” to exit “Selection Management”.
8. Use the “Edit Table” command to edit the table.
9. Click the cell on the right side of “CIRCLE” and click ooy -Reiu (1) fhre falt e
the “Insert Function” icon, as shown below:

10. In the dialog box, you can specify the entity as “CIRCLE”, Layer as “All” and click “OK”.

Je  Reset Dim
2 Text Text Value

Group Name: Group Name:
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PN A
Home Insert Page Layou

AutoXisTable ~ 2, @ |2, ¥ & 22

Menu Commands Custom Toolbars & Insert Function [
B2 v (= £
" Block Calculate
| A B ~ CAD Block Calculate
1 |OBJECTS AREA Block: | | Laper | | T Attribute
2 |CIRCLE T = vale: | =
3 |RECTANGLE )
- @ Area Calculate
[~ CAD Area Calculate
Entity: m Layer: m Factor: ,1_ ‘

ETE T T T—

" Length Calculate

File Home Insert Page Layout 3
o 5 s == [~ CAD Length Calculate
oxsanie <| 3 @ #, W B
‘f#:b" = - b Entity: | Layer | | Factor |1 ‘
@ RangeImport |
I#f, InsertFunction pstom Toolbars Cancel
\ W Delete Function | (© £ | 60.4¢
& options... B €
|28 Tools... IREA
2 CIRCLE 110.08
3 |RECTANGLE 60.49
4
. . i & 14
11. Use the same operation to insert the rectangle area = A g 3 B
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13.  GstarCAD Tools

Drawing Scale: You can set the drawing scale before drawing, when you are using other tools (for example “Line Such as Chord”
and “Modify Line width”), our software will adjust the scale automatically.

Menu: Express>GstarCAD Tools>Drawing Scale

Command Entry: SASCL [speciy newpoine. B2 J[<s0- |
Operation steps:

1. Start the command.
2. Input a drawing ratio and enter to finish. comand: _rtcura

ENTER to use last point[Follow]<Start of line»:

[Angle/Length]<End point>: m

Rotate Cursor: The cursor can rotate anti-clockwise by 0 degree or 45 degree.
Menu: Express>GstarCAD Tools>Rotate Cursor>0 or 45

Command Entry: RTCURO/RTCUR45

Side Line:  Menu: Express>GstarCAD Tools > Rotate Cursor>Side Line
Command Entry: RTCUR1 [Specity next pont:_ B[E0 <% |

Operation steps:

1. Start the command. Fease seloce the reference line: ]
. . . Command: L X X D

2. Select the reference segment and system will align the X axis of the cursor to EMTER €0 use last point[Follow]cstart of line>:
[Angle/Length]<End point>:<Ortho on> <[ r

the selected segment.

Real Time Rotate:

Menu: Express>GstarCAD Tools>Rotate Cursor>Real Time Rotate
Command Entry: RTCUR

Operation steps:
1. After executing the command, the command line prompts as below.
2. You can use the AWSD four keys to control the cursor direction until you are satisfied and press enter.

Fommand: _rtcur
___[:ou.r\terclockwise coarse (A) / clockwise coarse (D) / counterclockwise Fine Tuning (W) / clockwise Fine Tuning (S) / normal (0):0

SNAP  GRID poLAR [ESUNGN OTRACK  LHT

Draw Axonometric Line: Using this function can easily draw an axonometric drawing.

Menu: Express>GstarCAD Tools>Draw Axonometric Line
Command Entry: SALPL
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Operation steps:

1. Start the command and input the line width value.
2. The command line will prompt as below, input corresponding options, /
you can use it to switch between 0 degree and 45 degree and you can also
input any angle value. Then press Enter to finish the command.

(Command: salpl
Please enter a drawing line width: <@>Starting point

back to back (U)/input angle(I)/@ degree(.)/ 45 degree(/)/<next point>:
back to back (U)/input angle(I)/@ degree(.)/ 45 degree(/)/<next point>:
back to back (U)/input angle(I)/@ degree(.)/ 45 degree(/)/<next point>:
back to back (U)/input angle(I)/@ degree(.)/ 45 degree(/)/<next point>:

Command :

Visual Extension: Normally after extension, the extension effect will be displayed,
but Visual Extension can display the effect in real time until you confirmthe . ‘
position. LA
Opposite corner:
Menu: Express>GstarCAD Tools>Visual Extension S:;'.:“’g
Command Entry: ETT Commni
Opposite corner:
Command: <

Operation steps:

1. Start the command.

2. Select the line that needs to be extended, the system will choose the nearest side you clicked as extension side
automatically.

3. Move the cursor and the segment will extend in real time.

Normal Connect: The Normal Connect function is similar to zero distance chamfer, it can delete the lines of actual intersection
or apparent intersection parts.

Menu: Express>GstarCAD Tools>Normal Connect

Command Entry: GXFILT / /
\

Operation steps:
1. Start the command.

2. Select the first line segment. The second ez
The first segment
3. Select the second line. T

4. The result will be as shown in the picture.

Flex Connect: This function can extend or cut down the line to the actual intersection or apparent intersection point.

Menu: Express>GstarCAD Tools>Flex Connect .
Command Entry: GXFSS “--
n
Operation sample: =
Please select the elongation (or shortening) of the line:
1. Start the command. Tlence ctect the slongation (or shoreening) of the Line:

Cancel

Command :
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2. Select the elongation (or shortening) of the line.

Super Fillet: This function can not only do the fillet operation but can also
unify the filleted line layer, color and line type and the unified standard

will take the first selected fillet object as reference. . "-__ /\
w’ “'l

. e —
Menu: Express>GstarCAD Tools> Super Fillet (Comet

Please enter a rounded radius <1@>:
Please choose the first root segment (decision layer, color, line type):

Command Entry: SFILLET Fhease choose the Firet roor septont (decision layer, color, e ype):
Operation steps:

1. Start the command and input fillet radius.

2. Choose the first segment, as shown below. After executing the command, the layer, color, line type of another line and fillet
will match with the first segment.

3. Choose the second segment.

| Command :

Modify Linewidih: Modify the line width you specified, if what you specified is a line and our software will convert the line to
Pline automatically and change the line width. This function is similar to the pedit function, we can use it as a shortcut version
and it is very convenient for modifying the line width.

Menu: Express>GstarCAD Tools>Modify Linewidth
Command Entry: LCW

Operation steps: I
1. Start the command. Q
L |

2. Select the line. Dppeslt corueriEInd ot 2, ftal 2
Select objects: . .
3. Enter a new line width value and here we input “2” for example. Onebie oo recagnine ontry: Plesn oy again.
o ) ) . Unable to recognize entry. Please try again.
4. Enter to finish and the effect will be as shown in the picture. Comands

Cross to Break: In engineering drawings, many places need to break the cross line. If we do this the original way, it will be very
complex. Using this function breaking lines can be easily done.

Menu: Express> GstarCAD Tools>Cross to Break
Command Entry: CBK

Operation steps:
1. Start the command. ook

Please specify the occluded line:
Please choose the occluded(To be disconnected) line:

i i Please choose the occluded(To be disconnected) line:
2' SpeC”y the OCC|UdEd |Ine Please choose the occluded(To be disconnected) line:
Please choose the occluded(To be disconnected) line:

3. Choose the occluded (to be disconnected) line and what you selected will be |P1==== choose the occluded(To be discomected) Line:
cut off automatically. —
4. Enter to finish the command.
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Control Break Width: This function is used to set break width for cross objects.

Menu: Express>GstarCAD Tools>Control Break Width
Command Entry: CBKWID

Operation steps:
1. Start the command.
2. Enter the width of the break space.

Modify Text: In here you can find several tools to modify text properties.

Text Height:
Menu: Express tools>GstarCAD Tools>Modify Text>Text Height
Command Entry: TXT40

1. Start the command.

2. Select a single line text.

3. Input text height.

4. Press enter to finish the command.

Width Factor:
Menu: Express tools>GstarCAD Tools>Modify Text>Width Factor
Command Entry: TXT41

1. Start the command.

2. Select a single line text.

3. Input Width height ratio.

4. Press enter to finish the command.

Angle:
Menu: Express tools> GstarCAD Tools>Modify Text>Angle
Command Entry: TXT50

1. Start the command.
2. Select a single line text.

Command :
Enter the width of cross-quick break<S.@ee>:5

Command :

SAMPLE S #
Commandr 000000000000

(Command :

Select Text (can be multi-selected, automatically filter out non-Text entities):
Select objects:Find out 1, total 1

Select objects:

Surface-height <carriage return does not change>:

Command :

Command : 0™

SAMPLE g s i b

Command :

Select Text (can be multi-selected, automatically filter out non-Text entities):
Select objects:Find out 1, total 1

select objects:

Width height ratio <carriage return does not change>:

Command:

Command: <0

SAMPLE &%

non-Text entities):

3. Input rotation angle.

4. Press enter to finish the command.
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Obliquing Angle: Different to the rotation angle, after executing the command, the text will get an inclination deformation effect.

Menu: Express tools > GstarCAD Tools>Modify Text>0bliquing Angle

Command Entry: TXT51

1. Start the command.

2. Select a single line text.

3. Input tilt angle.

4., Press enter to finish the command.

SAMPLE 4.t~

Select Text (can be multi-selected, automatically filter out non-Text entities):
Select objects:Find out 1, total 1

Select objects:

Tilt angle <carriage return does not change>:

| Command :

Opposite corner:

Command : « Q

Options Modify: You can use this function to modify all the options above.

Menu: Express tools>GstarCAD Tools>Modify Text>Options Modify

Command Entry: EDTXT

Super Axonometric: It is a quintessential function that can easily convert a plan drawing to an axonometric drawing.

Menu: Express> GstarCAD Tools> Super Axonometric
Command Entry: ZC

Operation steps:

1.Start the command.
2.Select objects and press enter, as shown below.

3.Enter the axonometric point of view, such as 45 degree.

4 The effect will be as below.
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14.  Plot Tools
Print PLT: Users can send PLT files to printer for printing.

Menu: Express tools>Plot Tool>Print PLT Command Entry: PrintPIt

Operation Steps:

1. Start the command.

2. Select PrintPlt.exe in the dialog box.

3. Double-click the PrintPlt.exe file, then the “Print” dialog box will be
displayed, in the dialog box you can select printer or change settings.

|| GstarCAD mechanical drawing management frame engine
[ Tianhe mechanical drawing management frame engine
Universal frame engine

4. Click the OK button, the “Open” dialog box will be displayed and you can select the printed file.

Batch Print: Batch print drawings with the same drawing frame attribute.

Menu: Express tools>Plot Tool>Batch Print
Command Entry: BP

Operation steps:

1. Start the command.

2. Specify the type of frame, you can select Layer/ Block/ Polyline so that
the system can recognize the frame.

3. Corner select the frame you want to print, you will get a dialog box.

4. Set the print Parameters, click “OK” to execute bath print.

Arrange Frame Automatically: This function can search frames
automatically, calculate according to the size of the frame and then
arrange several drawings to a big drawing.

Menu: Express tools>Plot Tool>Arrange Frame Automatically
Command Entry: FRAMEAR

Operation steps:

1. Start the command, a dialog box will pop up.

2. In order to get a reasonable drawing plot arrangement, you can
choose which industry you want to use in advance. Click “Options’
and you will get a dialog box.

Batch Plot Setup
Specify batch setup
Select from
EEEREEE o vl dewn
[Cunent window: (21.94,259.12),(267.23,62.53) Re specly
i selected box
)Acoording to the selected info, need to plot 2 frames

Plot Setup_Options

Platter Name: | Canon MF4400 Series UFRII LT v
Page Name: ‘Model Paper Size: | A4 v
::‘;}SSPM [Yes Style Table: | None v
Flot r(es Drawing ‘Porllait&Nul upside-down
Linewidths: Orientation:

Orientation -

@ Center O Dffset K= ‘[r 000000 Y= "@ 000000

Plot

Plot Objects: l Plat to file v ]

i . PLOT Extended [pLT Delete existed

Prephane PLOT. [geeis i LT duplcate il

Saved Location: ‘E:\Plogram Files\GstarCAD2013 Profess| Browse...

Plot Scale
OFitPaper  (FixedScale  Scale 1000000 1000000
Units: "‘T“ﬁ’“e‘e’

Apply to Layout

|

«

[ imeetfie | [ Removefie | [ Esputlist | [ Ficpropeties |
Drawing Size Page Sefings Blocks nterval
@ A0 Format plotter () Other Paper length 11890 Horizontal interval

20
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Arange preview
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3. Click “Insert files”, an “Add file Manner” dialog box will pop up, you can set the manner

you like to add to the file.

Folder: This option will add all the DWG files from the root directory to the arranged list, if
you check “File that contains subfolders” option and all the DWG files from subfolders will be

added to the arranged list.
Drawing list: Add specified LST file list.
File: Add specified DWG file.

4, After selecting, all the files will be in the list.

5. Click the “Preview” button to preview the arrangement effect. The
system will arrange the drawings intelligently according to the frame
above.

6. If you are satisfied with the effect, you can click “OK”, and then the
system will arrange the drawings and insert the drawing frames into the
current file.
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